LaTeX forum ⇒ TeX Live and MacTeXProblem with TexLive2007 (can't find latex.fmt)

Information and discussion about TeX Live distribution for all platforms (Windows, Linux, Mac OS X) and the related MacTeX: installing, updating, configuring
waxranger
Posts: 27
Joined: Tue Jan 22, 2008 11:58 pm

Problem with TexLive2007 (can't find latex.fmt)

Postby waxranger » Sun Jul 27, 2008 9:44 pm

I have installed TexLive2007 on Ubuntu Hardy Heron but can't manage to fix this compiling problem

when I run latex I get this:

This is pdfTeXk, Version 3.141592-1.40.3 (Web2C 7.5.6)
%&-line parsing enabled.
kpathsea: Running mktexfmt latex.fmt
I can't find the format file `latex.fmt'!

now, I googled this and there's a lot of stuff found on this topic but none of that really helped me.

I have installed the same software on Ubuntu Gutsy Gibbon and it worked fine

can somebody give me a hint?
(PATH variable to the binaries is set though)

regards
Fab

User avatar
localghost
Site Moderator
Posts: 9206
Joined: Fri Feb 02, 2007 12:06 pm
Location: Braunschweig, Germany

Postby localghost » Sun Jul 27, 2008 9:54 pm

The latex format is missing for some reason. Try to build the formats on your own. Open a terminal window as root user and type in the command to build all format files.
  1. fmtutil-sys --all

This should build all necessary formats and make the system running.


Best regards
Thorsten¹
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 42.2 (Linux 4.4.52), TeX Live 2016 (vanilla), TeXworks 0.6.1

User avatar
Stefan Kottwitz
Site Admin
Posts: 8207
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany
Contact:

Postby Stefan Kottwitz » Sun Jul 27, 2008 10:01 pm

Hi Fab,

did you install the texlive-latex package?
If fmtutil-sys --all doesn't help, check if the TEXINPUTS environment variable has been set, it should be empty during installation I think.

Stefan
Site admin

waxranger
Posts: 27
Joined: Tue Jan 22, 2008 11:58 pm

Postby waxranger » Sun Jul 27, 2008 10:24 pm

fmtutil did not work..

I think the TEXINPUTS variable is not set. I'm not sure to which directories this variable have to point?

It's a bit confusing because I didn't have to set this variable after the installation on Ubuntu Gutsy and TexLive worked on that system.

thank you guys for helping me out so far!

regards
Fab

User avatar
Stefan Kottwitz
Site Admin
Posts: 8207
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany
Contact:

Postby Stefan Kottwitz » Sun Jul 27, 2008 10:36 pm

Hi Fab,

just type
  1. echo $TEXINPUTS

at the command line and check the output. I would not use this variable, I just remember that it could cause a problem if it was set. If the output of the command above is empty we have to look for another cause.

Stefan
Site admin

waxranger
Posts: 27
Joined: Tue Jan 22, 2008 11:58 pm

Postby waxranger » Sun Jul 27, 2008 10:52 pm

yes, I echoed the variable and the output is empty.

The only difference between the two systems is the installation path. TexLive on the system where it's not working right now is not installed to the default path. I think the cause must be somewhere there. I might take TexLive off the hard drive again and reinstall it to the default path if this takes no end.

thanks
Fab

Ted
Posts: 94
Joined: Sat Jun 23, 2007 4:11 pm
Location: Columbus, OH
Contact:

Postby Ted » Sun Jul 27, 2008 11:02 pm

waxranger wrote:This is pdfTeXk, Version 3.141592-1.40.3 (Web2C 7.5.6)
%&-line parsing enabled.
kpathsea: Running mktexfmt latex.fmt
I can't find the format file `latex.fmt'!

now, I googled this and there's a lot of stuff found on this topic but none of that really helped me.

Did you Google the error message in quotes? I did that and found this:


That thread ends in the person fixing their problem. Fix for you?
-- Ted [home/blog]

waxranger
Posts: 27
Joined: Tue Jan 22, 2008 11:58 pm

Postby waxranger » Tue Jul 29, 2008 5:25 pm

Ted, thanks for the link. I did google this one before I posted the problem, didn't help me to fix it.

But I made TexLive work. The problem probably was AUCTeX. I did check apt-get for any TexLive binaries, because I've downloaded my TeXLive version from CTAN and installed off the cd media and not via aptitude. So there is a package called TexLive-base-bin which comes with AUCTeX. I think because I've installed the AUCTeX package before I did TeXLive off the CD, my system pointed to the wrong binary location?! (Although I did set the $PATH variable up to date right after the installation) Anyway, removed AUCTeX with apt-get remove and reinstalled it right after and now TeXLive is compiling fine.


Since that solved my problem, I'd like to ask for help on another..
when I want to create .dvi output, I get a .pdf. So I checked the binaries of TeXLive where the latex executable is symbolic linked to the pdftex executable. Is this the reason for my wrong output format? Never had this problem before

thank you guys for the support!!

regards
Fab

Ted
Posts: 94
Joined: Sat Jun 23, 2007 4:11 pm
Location: Columbus, OH
Contact:

Postby Ted » Tue Jul 29, 2008 5:29 pm

waxranger wrote:when I want to create .dvi output, I get a .pdf. So I checked the binaries of TeXLive where the latex executable is symbolic linked to the pdftex executable. Is this the reason for my wrong output format? Never had this problem before
No, that's not exactly the problem.

As of the latest version of TeXLive, all TeX is PDFTeX, but that name is deceiving. PDFTeX is just a TeX that can produce PDF's. You can use the --output-format switch to specify which format you want. For example
  1. latex --output-format=dvi myfile.tex
or
  1. latex --output-format=pdf
However, IIRC, PDFTeX will use whatever name its symlinked to to figure out what default output format it should use. That way if you call latex you should get a DVI and if you call pdflatex you should get a PDF (unless you force a change in format with --output-format).

Check your compiler configuration and add the switch if necessary.
-- Ted [home/blog]

User avatar
Stefan Kottwitz
Site Admin
Posts: 8207
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany
Contact:

Postby Stefan Kottwitz » Tue Jul 29, 2008 6:30 pm

Hi Fab,

check your document if you have a pdftex option set, for instance to graphicx like
  1. \usepackage[pdftex]{graphicx}

or somewhere else. If you use \pdfoutput=1 or the pdftex option for example to graphicx, color, xcolor or hyperref then pdf output will be produced, even if the output-format is set to dvi.

Stefan
Site admin


Return to “TeX Live and MacTeX”

Who is online

Users browsing this forum: No registered users and 2 guests