Search found 497 matches

by scottkosty
Sat Nov 25, 2017 6:02 am
Forum: LyX
Topic: "XeTeX is taking a long time" popup
Replies: 16
Views: 687

"XeTeX is taking a long time" popup

OK this was implemented at the following commit: https://www.lyx.org/trac/changeset/1eb41a88/lyxgit

You can see the ticket that lead to the commit here:
https://www.lyx.org/trac/ticket/8032

If you are willing to compile LyX, I can give you a patch that gets rid of the message.
by scottkosty
Tue Nov 21, 2017 7:27 am
Forum: LyX
Topic: "XeTeX is taking a long time" popup
Replies: 16
Views: 687

"XeTeX is taking a long time" popup

ExecutorElassus wrote:next time I'm running a big compile job, I'll try compiling again and let you know the exact popup message.


Sounds good. I just want to make sure I know what message you're talking about before I take the time to look further at the code.
by scottkosty
Mon Nov 20, 2017 9:25 pm
Forum: LyX
Topic: "XeTeX is taking a long time" popup
Replies: 16
Views: 687

"XeTeX is taking a long time" popup

The problem *isn't* that the popup occurs. The problem is that it isn't measuring compilation time correctly. When I'm running the CPU at 100%, that popup comes up after 3 minutes. If the CPU is otherwise idle, compilation runs for 8-9 minutes with no popup at all. So it isn't measuring "time ...
by scottkosty
Mon Nov 20, 2017 7:05 am
Forum: LyX
Topic: "XeTeX is taking a long time" popup
Replies: 16
Views: 687

"XeTeX is taking a long time" popup

Is there some threshold number of "completed steps per unit time" that triggers that warning? Is this timer also supposed to catch compilations if the compilation hangs (such that active compilation stops, but doesn't exit, getting stuck), and not just measure/respond to how long the job ...
by scottkosty
Thu Nov 16, 2017 8:09 pm
Forum: LyX
Topic: dark background on Lyx Mac
Replies: 6
Views: 274

dark background on Lyx Mac

I logged in as administrator and searched for the preferences file in the Lyx directories but did not find it. Apparently, Lyx only saves a file if the user changes any settings. I did look for the background color in the Lyx preferences and the default color was the usual cream color not the dark ...
by scottkosty
Mon Nov 13, 2017 12:04 am
Forum: LyX
Topic: dark background on Lyx Mac
Replies: 6
Views: 274

dark background on Lyx Mac

Now, as to why the colors are screwed up in the first place for user accounts and not for the admin, this seems like a bug to me but I will leave it to someone more knowledgeable about Macs to post the bug. Could you open a new trac ticket for this? Also can you post your "preferences" fi...
by scottkosty
Sun Nov 12, 2017 8:33 pm
Forum: LyX
Topic: dark background on Lyx Mac
Replies: 6
Views: 274

dark background on Lyx Mac

Thanks for the details. Yes, it's unfortunate the lists are down. There was a hard drive failure. We're hoping to have this fixed soon, and also eventually move to a more robust system to avoid similar problems in the future. As for the bug, is this the same as https://www.lyx.org/trac/ticket/10740 ?
by scottkosty
Thu Nov 09, 2017 7:42 am
Forum: LyX
Topic: Restoring the default bind file in LyX Topic is solved
Replies: 7
Views: 3210

Restoring the default bind file in LyX Topic is solved

laposte, do you still have the old original preferences file? I would like to take a look. It's possible we can fix a bug.
by scottkosty
Thu Oct 19, 2017 7:11 pm
Forum: LyX
Topic: Math Symbols Missing After Being Updated to Win10 1703
Replies: 3
Views: 389

Math Symbols Missing After Being Updated to Win10 1703

I never have a chance to try it so am not sure if this works. Maybe people with a similar problem can try it if reinstalling MikTeX and LyX doesn't work. Yes this would be good to know. Also, if anyone is interested in testing 2.3.0rc1 (which will be hopefully released soon), it would be good to kn...
by scottkosty
Mon Oct 09, 2017 5:09 am
Forum: LyX
Topic: Math Symbols Missing After Being Updated to Win10 1703
Replies: 3
Views: 389

Math Symbols Missing After Being Updated to Win10 1703

It might be a system font that is missing? I don't know. Unfortunately I've heard about a lot of problems like this on Windows. It looks the same as this one: https://tex.stackexchange.com/questions/386454/math-symbols-displayed-incorrectly-in-lyx I wish I could help more, but I really don't have an...

Go to advanced search